MS Excel - Unire Dati di fogli diversi in base a una chiave univoca comune

  • 04
  • Apr 2013
  • Dev @ Contech Lab
  • View: 74731 | 0 Comments

  • Excel

  • Come realizzare un Foglio di lavoro Excel unendo i dati provenienti da due Fogli o File Excel, tenendo conto della corrispondenza univoca tra due campi dei fogli di lavoro


     

    Supponiamo di avere due anagrafiche Clienti di cui consideriamo il codice fiscale come chiave univoca da utilizzare per il collegamento dei dati

    Di seguito una sintentica procedura che funziona:

    • Aprire il File2
    • Aprire il File1 da Apri
    • Posizionarsi in una colonna libera del foglio1 dove si vuole ottenere l'unione dei dati.


    Inserire la Formula seguente:

    =CERCA.VERT(A2;Foglio2!A1:D5;1;0)

    dove A1:D5 sarà l'intervallo del Foglio2 dove si vuole andare a cercare il valore corrispondente a A2 del Foglio1

    Il valore 1 dopo il ; inidica a Excel quale dato sarà riportato a seguito della verifica



    Ripetere questa funziona per portare eventualmente altri dati dal foglio2 al foglio1 cambiando l'indice 1 in 2,3,4 a seconda della posizione del valore da portare

    Per migliorare la funzione è possibile anche inserire una funzione che esegua un test e gestisca eventuali errori,come segue:

    =SE(VAL.ERRORE(CERCA.VERT(A2;Foglio2!A1:D5;1;0);"";CERCA.VERT(A2;Foglio2!A1:D5;1;0))